My soundcard is glitching, stuttering or whining


My soundcard is glitching, stuttering or whining

Author
Message
Andrew Burns
Andrew Burns
Support Engineer, P Squared Ltd.
Support Engineer,  P Squared Ltd. (21K reputation)Support Engineer,  P Squared Ltd. (21K reputation)Support Engineer,  P Squared Ltd. (21K reputation)Support Engineer,  P Squared Ltd. (21K reputation)Support Engineer,  P Squared Ltd. (21K reputation)Support Engineer,  P Squared Ltd. (21K reputation)Support Engineer,  P Squared Ltd. (21K reputation)Support Engineer,  P Squared Ltd. (21K reputation)Support Engineer,  P Squared Ltd. (21K reputation)

Group: Forum Members
Posts: 82, Visits: 466
With the new generation of Intel Core i3 i5 and i7 CPUs and Intel Chipsets we have discovered a problem with some soundcards generating a whining noise through the audio channels out of the card.  This seems to primarily effect the M Audio Delta range of cards, but may have similar issues with any PCI based soundcard.

The cause of the problem seems to stem from the processor clock adjustment features that enable the Turbo mode features and allows for power reduction when under low load.  We have only experienced this on Gigabyte Motherboards with Intel Chipsets, but that is because many of the PCs we sell ship with these.  I can not say if it will be a problem with other Motherboard Manufacturers or Chipsets.  I can say that this seems affect both the P55 and P67 chipset that are in use on most current generation boards sold over the last 6 months or so.

To resolve the issue on these boards you will need to alter a BIOS setting that changes the way the CPU is run at idle.  Please be aware that altering the wrong BIOS setting may result in your PC not starting up correctly, so if you are not sure what this means then ask an IT person to take a look at it for you.  The instructions below are for a Gigabyte GA-P67A-UD3-B3 model board with an F3 BIOS, so you may have to look in a slightly differnt place if you have a different board.

Hit the DEL key as the PC reboots in order to get in to the BIOS, then look through the menus for:

MB Intelligent Tweaker (MIT) > Advanced Frequency Settings > Advanced CPU Core Features > CPU Enhanced Halt (C1E).

The default value for this Auto and needs to be changed to Disabled.

Once done, press escape until you get back to the main BIOS screen, then choose Save and Exit.

Your PC should now restart as normal, but should no longer generate the noise through the soundcard.

Regards,

Andrew
Edited
10 Years Ago by Andrew Burns
GO


Reading This Topic


Login
Existing Account
Email Address:


Password:


Select a Forum....





























Broadcast Radio Forums


Search